New Security module with 2fa does not work


I implemented the new security with 2fa. when I was done, I enabled the 2fa and entered the code. It was enabled successfully.

The next time I tried to log in, It send me a code, but It did not let me log in anymore when I entered the code.

Here is the error:

Fatal error: Uncaught Error: Call to undefined function sc_logged() in F:\scriptcase\wwwroot\scriptcase\app\security2\appV3_control_2fa\appV3_control_2fa_apl.php:3276 Stack trace: #0 F:\scriptcase\wwwroot\scriptcase\app\security2\appV3_control_2fa\appV3_control_2fa_apl.php(2042): appV3_control_2fa_apl->sc_validate_success() #1 F:\scriptcase\wwwroot\scriptcase\app\security2\appV3_control_2fa\appV3_control_2fa_apl.php(1306): appV3_control_2fa_apl->Valida_campos(NULL, NULL, NULL) #2 F:\scriptcase\wwwroot\scriptcase\app\security2\appV3_control_2fa\appV3_control_2fa.php(2791): appV3_control_2fa_apl->controle() #3 {main} thrown in F:\scriptcase\wwwroot\scriptcase\app\security2\appV3_control_2fa\appV3_control_2fa_apl.php on line 3276

I suspect that the error happens in sc_logged () in screenshot below(under ***_control_2fa app):

Anyone know how to fix it?

I reported this to SC last week. The feedback was that they are aware of it and busy with the fix


Just had feedback from SC. Still in correction phase.

1 Like

Thank you Nico. Please let us know if you get any update

I am still waiting an feedback on this. Nothing has been done in more than a month

Check in internal libraries if sc_logged.php is checked

@gbillot3 , thanks for the feedback. Yes it is checked. SC is aware of the bug and they did indicate more than a month ago that they will be looking into it

2 Months later and still no feedback from SC :frowning:

I pay for support and I’ve been waiting for a solution for three years, wait and hope.