Oracle connections

Has anyone gotten SC7 development to connect to an Oracle database on a linux host? I have tried with both the instant client and the XE edition and both generate an error before even attempting to connect to the database.

Error while trying to retrieve text for error ORA-01804

I have the following items set in the environment for all users:

export ORACLE_HOME=/u01/app/oracle/product/11.2.0/xe
export TNS_NAMES=$ORACLE_HOME/network/admin/tnsnames.ora

Please let me know if there is something that I am missing. I had both clients working in SC6, but they will work with SC7.

Any suggestions?

Thanks in advance

Just some additional information. I am able to connect ceom commandline through sqlplus to the database. Also I get this error in scriptcase database setup when ever I test a connection even when there are no server details. I also added the in the extensions for the php.ini used by scriptcase.

Does anyone else have any additional thoughts on where the configuration might be wrong?



Have you restarted apache after adding to the extensions? Is oracle enabled on your diagnosis (Help --> Diagnosis --> Click here to see more info…)?

Please see:

Bernhard Bernsmann

Thanks for your responses.

Yes I checked the diagnosis page and I see that Oracle 8 and PDO Oracle 8 are both enabled. The only oracle related item with a red X is the generic oracle database connector which I believe is only used for connecting to very old databases. Attached is a screenshot from the diag screen.

Please let me know if there is any other configuration information that I can provide that might be helpful.


Screenshot from 2013-02-07 16:06:24.jpg

oh forgot to mention that yes I have restarted apache and the system as a whole. Still there is the same error when trying to configure an oracle connection for types oracle 8.0.5 or higher, oracle 8, and oracle 8 portable. The older Oracle 7 and ODBC are not configured on this system so I dont expect them to work. This types give a php error about no extension loaded as expected.

Any other thoughts?


      Is there an english version of the page you linked to? I followed it hte best that other than the screen shots I was not able to understand much of it.  From the looks of it, on linux the directions are unzip, add to path, and start SC and it will work.  

Jason Franks

info.php snippet

SC Community,

    Here is the OCI8 section from info.php  I didn't know if that would help ornot.  So here is a screenshot

Thanks for any help you can provide…

Screenshot from 2013-02-07 16:35:02.jpg

It helps a lot :smiley:

Sorry about the wrong link, here is the same tutorial in english:

If you are still unable to connect, please contact our support. Our chat is active on workdays from 8:00am to 6:00pm, and our ticket system is always available.

Bernhard Bernsmann

Sorry for the delay, I had to shift to another project for a few days. Still not able to get this working. Its currently Friday @ 4pm EST, and the support chat is not online. And everything digital says that I need a support contract to initiate any type of support.

Has anyone on the forum been able to get v7 to connect to an oracle database under any conditions? Please report back any successful oracle connections through the new software. I have tried with the instant client, oracle XE, and next week I will give the full oracle client a try. But I dont see how it will make a difference. The web server is able to see the but the connection attempt never actually is made. Same error if there is connection information or not.

Any thoughts? I will resume trying to contact the support team next week to see if there is any hope of fixing this setup.