PDF creation error

Hi all,

I’m deploying an application in Advanced Mode for a Windows operating server but when trying to export a PDF from a grid, I get this error message:

There was an error during the PDF creation. The operating system on which the application is running is not the same as chosen during the deployment configuration.

I doublechecked deployment routine several times but I can’t find the error.
On development server I run PHP version 7.3, on Windows Server 2016 with IIS I run PHP version 7.2.

Anybody any idea what could run bad here?

Thanks for any help from the community!

A ver si les funciona…

otorgar permisos 744 a archivos

_lib/prod/third/wkhtmltopdf/linux-amd64/wkhtmltopdf-amd64

Ahi pude generar pdf desde un grid !!!

Imagino que hay que hacer lo mismo en casos de i386 sobre

/_lib/prod/third/wkhtmltopdf/linux-i386/wkhtmltopdf-i386

habría que aplicar esto para equivalente a Windows.

Thank you for your reply.

I have this folder /_lib/prod/third/wkhtmltopdf/win with the right permissions but this folder is empty. There is no wkhtmltopdf-i386 or something else. Is this ok in this way or is there something missing?

What I forgot to mention before, I did an advanced deployment so the library files are not in the subfolder of the project but in a folder “scriptcase9” on the root level of the root level “httpdocs”.

para mi caso la carpeta

/ _lib / prod / third / wkhtmltopdf / contiene 2 archivos un index.html con permiso 0666 y un wkhtmltpdf_amd64 con permisos 0744, yo encontré la información que te envíé en google y me fue de mucha utilidad, pero no se que signifique. No conozco mucho de este tema, pero no me dejaba generar pdf del grid hasta que habilité los permisos.

As I work on an Windows Server the files and folder permissions work a little bit different but what is there has the right permissions. I suppose you work on a Linux environment.
My problem seems to be that in that folder there is any content. Or the problem is anywhere else… I will continue to investigate!
But thanks anyway for your answers!

Kind regards