PDF export on Digital Ocean Ubuntu 18.04 droplet

I’ve gotten excel, csv, word, rtf to work but pdf refuses. Tried a number of suggestions on this forum but none have resolved pdf export: the file exported is zero KB, clicking view button shows 404 not found error.

Has anyone had any success getting it to work in this environment? I’ve had it working whilst hosting on webfaction (CentOS I believe.) I’m sure there is just a little item I’m not aware of somewhere…

Did you follow the instructions on the following link?


The output of the command in the log file would help you figure out what could be going wrong.


Never seen this, will give it a shot. Thank you


i am starting with digital ocean linux india server…i hope pdfs work… will update here.

So the log simply showed the command line instruction being executed, no errors.

The .html file was correctly being generated but wkhtmltopdf was failing. Copying and pasting the contents of the log into command line gave the errors listed in [this] (https://github.com/wkhtmltopdf/wkhtmltopdf/issues/3923) post. Installing the libssl1.0.dev specified there got it working.

Other problem: the url parameter sent to wkhtml in the log file is http but my server is running on https. Not exactly sure where to change this.

i had same problem on centos 7. after trying various options, what worked was changing the chmod of the file: wkhtmltopdf-amd64.
before 644
now 744