Problem: CSRF The token validation is invalid

Problem: csrf The token validation is invalid
Hi, I have developed a procedure with scriptcase 8
Apache Version: Apache / 2.4.17 (Win32) OpenSSL / 1.0.2d PHP / 5.5.30

The procedure can be reached via the intranet VPN

And in SSL protocol mode

https: //

At the beginning, it requires the user and password to be entered.

In both methods everything works perfectly.

Having also available version 9, I decided, through the conversion procedure made available by scriptcase, to convert the project from version 8 to 9.

I accordingly updated the production environment to the version:
Apache Version: Apache / 2.4.25 (Win32) OpenSSL / 1.0.2j PHP / 7.0.15.

I am using 32bit scriptcase version 9.5.003 with php 7.0.

In an intranet VPN environment, everything works.
I noticed, however, that when you log in with SSL protocol, once you have entered the user and password, the message is displayed:
CSRF: The CSRF token validation is invalid
What can it depend on? When I was using version 8 I didn’t have this problem.
If I don’t solve this problem I can’t migrate all procedures to scriptcase 9.
Thank you in advance for any support.

try to clear your browser cookies

or try the incognito mode of your browser


Hi, thanks for the reply.
I tried but it still doesn’t work.
I had seen that this problem was solved by the version
ScriptCase 9.2.015 (32-bit and 64-bit)

  • Fixed CSRF Tokken problem when accessing control and form applications
    But to me when I log in in ssl mode it still doesn’t work with version 9. With version 8 everything worked perfectly.
    Too bad, I can’t use the new version this way.
    I am forced to stay on version 8, even though I bought version 9.
    The only thing I haven’t tried is installing the 64-bit version with php 7.3. But I should migrate all projects. I am stuck at version 7.0 of php and scriptcase V9 5.003.
    Thank you

It’s rare, I work with 9.04.0032 (and php 7.3) and it works fine. I’ve never had this issue since work with v9