Problem Editing or Creating Connections

I am using the trial version to test if the applications can work in my hosted site (it has all requirements: php 5.2.17, mysql 3.23.58). I created a very simple project in my computer and I followed the instructions to deploy it using the FTP option. I changed the permissions for the _lib directory and subfolders and files to 777-R (as indicated)

Now, when I tried to access the prod environment I had some errors that I tried to solve myself

  1. At the login page nothing was displayed. The language list was empty and there was no text. What I did was to modify the nm_ini_manager2.php file so it could show the es-es language (my native language is spanish). Apparently there is an error with the $_SESSION[‘nm_session’][‘prod_v7’][‘lang’] value for spanish.

  2. After that, I was able to have access to the prod menu, but when I clicked to create or edit a connection, there were other errors related to the $nm_config[‘path_lib’] variable. I changed it to direct it to the correct directory. after that, I had another error in the admin_sys_allconections_create_wizard.php file. It did not find the file at the instruction where the program includes the ' file. Once again I edited the path.

  3. Finally, the instructions “$obj_page = new nmPageAdminSysAllConectionsCreateWizard();
    $obj_page->Display();” seemed to work because I did not receive any errors but again nothing happens and this time when I clicked Create or Edit a connection, nothing happens.

I have ran out of ideas. Could you help me to understand why I am having path problems and I can not create or edit database connections?

I would really appreciatte your answers. I think this program has a lot of advantages but I need to be sure this tool can be used in my hosted site or any client’s hosted site.

Please use php 5.3.x in your hosted site.

To deploy it is simpler, you create an .zip file, upload that und unpack the whole packet. I use this update.php in the app folder:

system("unzip -o <yourapp>.zip");

Problem connecting…

[QUOTE=RHS;17304]Please use php 5.3.x in your hosted site.

To deploy it is simpler, you create an .zip file, upload that und unpack the whole packet. I use this update.php in the app folder:

system("unzip -o <yourapp>.zip");


Thank you very much for your answer, but unfortunately as my website is located in an external webhosting service (not dedicated server), I can not update php or mysql versions. Is there any difference if a zip my app folder instead of deploying it using the FTP option that scriptcase has? I do not see the difference.


Please contact our support regarding this issue.

Bernhard Bernsmann

I have a problem in deployment.

I am using scriptcase ver 7 and using a shared free hosting site to test the concept before enrolling.
I deployed to .zip file , extracted the files and then transferred using filezilla FTP , changed permissions to 777.
Database is sql5.6 and the required tables are in the database of server.

Now in the first page of website, that is /_lib, it leads to
message " some of the database connectors are not properly configured and the connector icon “MYSQL56” appears. When I click it to configure it gives 404 file not found error.
what could be wrong? please advise


What kind of connection are you using? pdo or native. Since standard connections are just tcp/ip I suspect you are using a pdo_ driver which is not supported on your hosting party. But it’s a guess to be honest. Another possibility is that you haven’t done a full upload and something’s corrupt. You could try to reupload your site. Under normal circumstances you need to go to _lib to be able to logon to your admin and apply password and server connection.