prod-Server php.ini-path not set

can anyone give me a hint, how to solve this:
the diagnostics run on the prod-server tells my, that the php.ini-path is empty.
I want to set it correctly, so that I can in the next step set the seesion_write permission, which also is not set.

Any help is gratefully welcome.


what kind of production server are you running? On a service provider, your own virtual/dedicated server, windows/linux etc? If you install things from a wamp package (i.e. uniform, wamp, xamp and others things are useually set by default).

I run a vritual root-server by Strato, Ubuntu Linux on it
I installed the prod via ftp and via zip-files.
Both show exactly the same result, behaviour and diagnostic results.

There three things shown negativ: php.ini-path is empty, session_write_permission is off (some on mac-system which I use for develpment with sc7-installation-server), zendid is off.
The first grids show up correctly, but the pdf-export does not work.

Set the permission for files in _lib/prod_third/wkhtmltopdf to 755 and try again.

Checked that, is ok.
But even with 777 no success.

There three things shown negativ: php.ini-path is empty[/QUOTE]

Ok, look first at Strato FAQ and edit your php.ini: Click!

thanks for trying to help. I know the location for the php.ini, the question is: why does sc7-diagnostic stat php.ini-path empty.

Haveā€™nt I do change settings in sc to make path visible?

I have the same problem: on my production environment diagnosis.php does not show the php.ini file. I know the location, but how can I configure this in scriptcase?
My production environment is a synology with DSM 6.x (linux 64 bit, apache 2.4.27, PHP 7.0.21).

Additionaly diagnosis.php shows, that execution permision is deactivated. Is this for production needed?

I tried to run some applications created with SC. I works almost. But not grid applications with nested grids (master - detail): in this applications the functionality is given, but only in plain text (no theme is working (I tried different theme, but nothing helps)).

Has someone an idea, how to solve this problem?