Quicksearching dates

Can Quick Search be used with date fields?

Entering a date in quicksearch in a grid doesn’t return the corresponding records .

Also, if I edit the grid and in “Search>Quick Search>Select Fields” I select only dates fields, the quick search box will disappear from the grid when run.

I was trying to accomplish the same thing, with no success.

Possible Workaround: Adding the date field to a dynamic search and selecting appropriate criteria.

Some of the search criteria (at least for dates) seems strange - either a bug or a feature, depending on your view:)

If you want to search for records between certain dates (date 1 -> date2), if seems that the logic is >= date1 and < date 2. So to include date2 records, you would need to add a day to the end date2 to include those records.

Perhaps someone else has a better experience with quicksearch (or a better workaround).

Quick search can not directly handle date fields, but you can use quick search and advanced search on the same grid. As a workaround for quicksearch you can use a select statement with a date field and format that as a text string … ;).

Your workaround is a good idea.
Still it would be much better if quicksearch worked with dates.

I’m with you too, I’d prefer a lot to write a single year and that searches the matching dates of the grid datetime fields… It’s a pitty that doesn’t work.

Hope this will be solved with sc9!

I just discovered that neither QUICK SEARCH or ADVANCED SEARCH does not work correctly. So any ideas when this will be fixed ???

There is no logic because for me the DATE2 works Ok but DATE1 is not wqorking at all so all records with date < than DATE1 still show up

OK, so NetMake confirmed that Quick Search is not working with dates. So what now ?
If this is a bug or missing feature it still needs attention because this is so basic, right ?

This feature it dosen’t work in sc9 :(. The advanced search works very well with dates (if you have configured) well

I think Quick Search also fails on searching for numerics even though they are VARCHAR fields.

So for things like zip code or street numbers, it is not working for me.

Quick Search has a nice feel about it, but a search button does not have the same appeal.

I talked to NetMake few days ago asking about SEARCH bugs and none of them are fixed so far. Niether Quick Search, Advanced Search, Date Range is not working at all. My concern is to search for records based on 2 dates and I’m very upset it is not working. Perhaps if we all push more on fixing those bugs they will do something (?)
Ho about idea if everybody interested will send separate Email to NetMake to create a trouble ticket ?

Te problem is that you can not send tickets to scriptcase if you are not paying. You can send bugs (As I several months ago), but I’ve not got a response.
Probably if we send a daily mail with this bug, someone will take care on that.

I have sent several Email to Netmake about this. THEY COMPLETELY IGNORE IT saying it is not a bug
! what a shame !

there’s still no update to this yet?

Nothing for fix this?

quick search seems to do not carry over the date formatting, so it searches it as text, which dates are not. they have numeric values depending on the database.
it will probably search dates if you type a numeric value for the date, which is of no practical use.
if you format dates as text, it might work, but this work around is ok only for a few scenarios.
in my installation quick search box never disappears
if you quicksearch not all but a date field , it would be awesome if SC did proper conversion for the searched field, which it does not.

i tested an advanced search which allows to use a date selector from SC and it works fine.