Running Deploy results in fatal error - memory exhausted


I am in need of some help - unable to deploy an update to my project at the moment - Fatal error as follows:

Fatal error : Allowed memory size of 2147483648 bytes exhausted (tried to allocate 36864 bytes) in /Applications/Scriptcase/v9-php73/wwwroot/scriptcase/devel/class/page/nmPagePublishWizard.class.php on line 1728

When the error appears the deployment progress bar is at 100% and it says “Generating Tar.Gz”. The fatal error (above) is displayed below.

This is an existing project and I have run deploy many times. This is the first time I have hit this. I have not upgraded SC for a little while but I have added 6 new apps, and I have obviously crossed some kind of limit. I am running SCase Ver. 9.7.10 on macOS Big Sur Ver 11.6.5, with a total of 32GB of RAM.

I tried increasing the PHP script memory limit by adjusting the value of the memory_limit value in the php.ini file to 4096M (4GB) and restarting apache. In a terminal window the command php -i | grep “memory_limit” produces the output “memory_limit => 4096M => 4096M”, which I believe shows the memory limit has been increased per the ini file.

So, is the limit reported above some other resource limit?

If so, can the amount of resource allocated be increased?

Are there other workarounds for this problem, such as splitting my deployment?


Cheers, Russell.

WORKAROUND - The workaround for this is to specify a ZIP file for the output rather than Tar.Gz. I am not an expert on archive file types, or the process for the creating them, but Tar.Gz seems to hit some kind of 2GB memory limit - which roughly equates to what the size of the output file would be based on previous ‘Deploy’ executions for the same project. Zip does not hit this problem, and the output file is far more compressed at about 330MB. Which also makes me wonder if Scriptcase is compressing the Tar Ball in the Tar.Gz file at all?

More questions than answers, but I have a workaround.