SC 9.8 minimum PHP version requirement

Hy all
quick question about SC 9.8 just released.

Will the application generated by SC 9.8 run also with PHP 7.4 ?

Can SC9.8 development environment run on PHP 7.4 or not ?

Just installed and tested with completed application export and import to 8.0
Recompile and deploy to php 7.4 server and all seems to be working fine so far

Hello, @maxi

Version 9.8 continues to run on PHP versions 7.0 and 7.3, only in development, that is, accessing the scriptcase tool. Now we are free to support the PHP 8.1 version, also in development.

Regarding PHP 7.4, it can only run in production, that is, in published environments. Starting with version 7.0, systems can run in production.

So in other words:

  1. SC 9.8 (dev) works in PHP 7.0, 7.3 and 8.1
  2. SC 9.8 generated apps work in production for any PHP version >= 7.0

Correct?

Hello, @scriptcaser

Yes, exactly

Hello i have installed the SC 9.8 for php 8.1 but it not working in 7.3 , what can i do becasue i have there proghram that work only in 7.3 , here toohow can i make îîsc 9.8 to work t

Not sure how to help as your explanation is not clear on the problem you are facing. What is not working?

i have an old application lets name it officemanager made with scriptcase 9 that is working on a host server with php 7.3 but now i upgraded my hosting php to 8,1and that application (officemanager) that was builded with SC( 7.3 dont work anymore

Have you regenerated the code?
Have you redeployed the code?
The question is. What is not working. What error message are you getting?

1 Like

If you have generated the application for PHP 7.3 then you cannot run it under PHP 8.1 as PHP 7.x has incompatibilities. To be able to run your application under PHP 8.1 you must:

Upgrade your Scriptcase environment to the version that supports 8.1
Migrate your custom event code to comply to PHP 8.1
Regenerate and deploy your application.