[SOLVED] Autocomplete text field with select2 does not trigger ajax processing!

I Think that the new select 2 option is awesome, but it fails to trigger a prior working ajax processing (to refresh other selects)

Tested in Firefox and Chrome win10.

Any clues?

Are you clicking on the option that appears during auto-fill? I have had issues with on change events not triggering because you have to actually click on option for it to save.

Yes i have, and it saves the record. My problem is with the ajax refresh on change event…

1 Like

Same issue.

When an autocomplete field is set to Select2, code created in Ajax events (onClick, onBlur, etc.) for that field is not executed anymore.

I’m on SC 9.2.007

1 Like


Recently we released several fixes to select fields using the select2 component. Could you check if this issue still persists?

​Thank you!

John Santos,

ajax events are now triggered with Select2, but theres’ still an issue, even with SC version 9.2.010

Please see this post: Still issues with Ajax events for auto-compete fields using Select2

Dear John:

Haven’t try it yet. Thanks!

Dear John: As far as i can tell, select and autocomplete with select2, does trigger the ajax update perfectly. Thanks!

My Select2 is not executing the ajax event

issue is not solved, Select2 is not executing the ajax event