[SOLVED] Chart Application Metrics Labels do not appear in the Custom settings toolbar


Very simple steps to reproduce this BUG with SC 9.5

  1. Create a chart application and set up its SQL statement

  2. In the “Charts” section, select 1 dimension et a few metrics.

  3. Unselect 2 metrics (see printscreen#1)

  4. In the “Metric Fields”, select the fields we have unselected in the previous step and set up their “Label” with a global variable (see printscreen #2)

  5. In the “onScriptIniti”, assign the 2 globals (see printscreen #3)

  6. Run the app and don’t fill anything in the globals prompts. Click the run button. See printscreen #4

  7. Click the “Custom” button on the top. The 2 available metrics don’t have labels. See printscreen #5. if on the previous step (6) you would have filled something in the global prompts, it would have been shown here. Remember we ahve modified the globals in the “onScriptInit” event.

  8. Drag-Drop the 2 metrics in the “Selected” list of metrics See printscreen #6 The labels on the metrics in the metrics list on the X axis are correct but the ones in the “Custom” toolbar are wrong.

Please Scriptcase team fix this as we use this feature extensively.

Thanks a lot.







[SOLVED] Found out that if this is made in the “OnApplicationInit” event instead of “OnScriptInit”, it works.