[SOLVED] ERROR Scriptcase PHP 8.1

He migrado varios proyectos, en uno de ellos en un GRID, tengo un error en la busqueda que no logro resolver.
El mensaje es el siguiente:
Fatal error: Uncaught TypeError: in_array(): Argument #2 ($haystack) must be of type array, null given in C:\Program Files\NetMake\v9-php81\wwwroot\scriptcase\app\Hardwind\consulta\consulta_pesq.class.php:3266

Alguno tuvo un problema similar para ayudarme ??

PHP 8.1 Test and feedback

Imported application on version 9.8.000 (57) and all worked pretty good

Did update today to version 9.8.000 (69)and all grid applications have error when generating

2 = A non-numeric value encountered
E:\NetMake\v1\wwwroot\scriptcase\devel\generator\nm_gp_consulta_prep.php 668


Errors found in PHP version 9.8 can be sent to support.php81@scriptcase.net

One thing I have done is: after updating SC, I run update again to see if there are files missed in the previous update. Only when the message “No updates found” appears, I can test my projects.

So do all your grid apps work perfectly after this approach?

Yes, perfectly!!! I don’t have any problems with this.

Unfortunately it still doesn’t work for me

But has your grid custom code in some event?

Is this portion your code or part of generated SC code? If yours, maybe there is syntax change from 7.x to 8.1?

1 Like

Scriptcase code …

No it hasn’t , thanks

And what if you create another grid, same as the first one and test?

Create a new grid without modifying any of the code and when confirming the search the same thing happens:

Fatal error: Uncaught TypeError: in_array(): Argument #2 ($haystack) must be of type array

Dear, @afpsistemas , @Kleyber_Derick , @Nico

the errors below have already been fixed.
The fix will be available in version 9.8.001.

  1. Fatal error: TypeError not caught: in_array(): Argument #2 ($haystack) must be of type array

  2. A non-numeric value found
    E:\NetMake\v1\wwwroot\scriptcase\devel\generator\nm_gp_consulta_prep.php 668

1 Like

Thank you very much for the information.
I have version 9.8.000 (69) and it tells me that it is updated, how do I get version 9.8.01?

We will be incrementing the version. It will update normally by scriptcase update, when it displays the message to update the version.

Version: 9.8.001

1 Like

Download and install 9.8 for php 7.3 to a new folder.
Ran scriptcase update to version 9.8.000 (69)
Created backup from current version 9.7.23 and tried import. This failed with message invalid not from sc9
I then exported 1 project and imported to new version. Import went well and I am able to edit applications.
When generating sources code the system generates about half way and then just stays on generating without increasing and no timeout.
I tried to compile separate applications and found that Calendar and forms don’t want to compile.
I am sure that they are working on the problems and this is just for feedback

I found error with a simple grid with no custom code.
When I add a condition on a field I get a fatal error

I try on other tables and it appears the SQL builder has bugs
I report on the free support but this is a thankless task - please show logs, screenshot everything etc etc just a delay whilst bug fixes are sorted.

Updated to latest version:
Still error on SQL Builder

Fatal error: Uncaught Error: Call to undefined function get_magic_quotes_gpc() in C:\Program Files\NetMake\v9-php81\wwwroot\scriptcase\devel\compat\base.php:216 Stack trace: #0 C:\Program Files\NetMake\v9-php81\wwwroot\scriptcase\devel\compat\nm_isql.php(566): nm_escape_string(‘Viv L’) #1 C:\Program Files\NetMake\v9-php81\wwwroot\scriptcase\devel\compat\nm_isql.php(2): sg_load(‘68ABBE04C7C5024…’) #2 {main} thrown in C:\Program Files\NetMake\v9-php81\wwwroot\scriptcase\devel\compat\base.php on line 216

1 Like

there we go,
thanks guys for testing, i think i will migratie to 9.8 in 1-2 years , while paying for the updates :slight_smile: