[SOLVED]Quick Search Double quotes problem

At the end of evaluating SC, we found a critical problem.
Searching Quick Search with string includes “Double quotes” results endless process!
No problem in Advanced search.
Any help will be Appreciated.

This looks like a bug to me.


I can confirm that this is a bug. I reported this to netmake. It’s an annoying bug and I expect it to be solved. It’s not a real showstopper if you have this application running under a menu. You can then simply select another application because other functions are still responsive. But that’s no ‘real’ solution of course.

Regarding double\single quotes breaking SC it’s not only with search.
Try to use a summary in a grid with a field that has some records containing single quotes (e.g. “d’amico”).

please report to NetMake the summary issue as well.


edit - i didn’t check if the latest versions have fixed it, but didn’t find anything on this topic in the changelog so I’m assuming the problem is still there.

Well to be honest working around quotes can be a pain sometimes, definetely when making a generator like this. Time to introduce the triple-quote("’) i guess.

I have reported this whole thread. To prevent false hope, I’m not an employee of SC and I don’t have the ‘power’ to solve these issues myself. Just sometimes my efforts help…

Thanks for your prompt replay.
This is a project is without Menu.
In my case, if you choose to search by clicking the magnifier, the only way to stop the endless process is to refresh/exit…
Sorry, with this so basic function not working properly, we will not buy SC.
Thanks again

Glad to be of help. Hope you’ll find a product that better suit your needs.
To others, the issue is acknowledged by SC.

To be more specific on the summary issue:

In a grid: run a summary once you’ve grouped by a field that has some records containing single quotes (e.g. “d’amico”).

This what I reported some time ago:

If I run a a grid and dynamically Group By a field where some rows contain an apostrophe, SC execute the group by with no problems.
But when I click on the Summary button (Group By still ‘active’) I get the following line repeated many times at the top of the page, followed by the summary correctly generated only for the rows not containing the apostrophe (i.e. no summary for the rows with apostrophe)

Parse error: syntax error, unexpected ‘AMICO’ (T_STRING), expecting ‘]’ in /opt/NetMake/v8/wwwroot/scriptcase/app/proProectWebEnd/grid_progetti/grid_progetti_total.class.php(249) : eval()'d code on line 2

Hi robydago,

I have reported this thread to SC, so let’s see what they are doing. I don’t feel responsable of testing each and every (possible) bug, I think that’s netmakes responsability.


This bug was reported to our development team for fix it.
When solved,the fix will be included in update release.
thanks for your observation.

Have a nice day.

best regard,
Netmake team

It was really a bug, is already in our systems to be fixed!

Thanks for reporting.

Think of the many hours of our time that could be saved if we could see that list of known bugs.


Not solved!!! still exist! just insert Double quotes ["] in the Quick search box, click on the magnifier inside the box and SC goes into endless loop…
Another problem with the quick search: if you take the magnifier outside the box, then “Enter” doesn’t work!