[SOLVED] WKHTMLTOPDF - still not updated!

For almost a year I have been writing mails and mails that Scriptcase updated the non working version 0.12.4 to the working version 0.12.6.

It is simply ignored.
What is so hard about that?

This is a cheek.

Hi, @gomi

Are you having trouble with the current version?

If so, please tell us about it.

We’re available to hear more from you and switch to the latest version if necessary.

since the latest update to mac/os big sur i had to install everything again and after publishing my pdf export also doean’t work anymore in the live version. in the development enviroment it works fine. can’t figure out what changed. all rights are 777

I shared it with you guys, but the bug team just closed the ticket.
No answer - nothing. The BUG team didn’t lift a finger.
Then Mateus Cardoso forwarded it to development - and again nothing.

It is known that wkhtmltopdf gives a segfault from Centos8 (and therefore also in Redhat).

kernel: wkhtmltopdf-amd[18914]: segfault at 8 ip 0000000001dcb782 sp 00007ffc0ab31b70 error 4 in wkhtmltopdf-amd64[400000+23d0000]

THIS IS KNOWN.
And the developers have been recommending to update to 0.12.6 for almost a year.

Scriptcase doesn’t care…

And again, like in elementary school, I send you the link

Clearly.
You develop in macos and therefore you use a different version.

Depending on which os the httpd is running it’s another version of wkhtmltopdf.

PS:
After each update I have to replace wkhtmltopdf.

This is annoying!
Only because the bugteam is too lazy.

I have been after them for more than a year. wkhtmltopdf is a problem only with Linux type installs, and it seems that the Scriptcase people don’t test on Linux equipment, so they find no problem. I have been told that the problem cannot be duplicated. Of course, it cannot. The people trying to duplicate are not allowed to try it on Linux or are too lazy to do so. In the meantime I have created a script to run to fix this issue each time that I deploy.

Maybe it depends on the flavor of Linux, I am running under Centos 7 and I don’t have this problem. What version of Linux are you using?

Ubuntu 18.04. You are probably right about the flavor that is running. What got me upset about the whole thing is how tech support just disregarded the problem. Finally in another forum topic here it was figured out by us users.

Centos7 still works with the old version.
Centos8 / Stream and subsequently RedHat no longer do.
But what should the developers of WKHTMLTOPDF do more than constantly tell you to update?

Paul, that’s OK. You can do that with free software.
But not with software for which we pay a lot of money for updates.
I’m not going to write a script.
Scriptcase should finally solve this.

Hi everyone,

Just to let you know that we’re going to update to the latest version.

It might not be in our next version, but surely won’t take much long to update it.

Thank you for understanding.

1 Like

that would be great! is they’re anything besides updating that you should do on the server side?

It depends on what environment you are deploying…

…//scriptcase/prod/third/wkhtmltopdf

-rwxrwxrwx 1 apache apache 0 Nov 18 2019 index.html
drwxrwxrwx 2 apache apache 49 Feb 12 12:34 linux-amd64
drwxrwxrwx 2 apache apache 48 Nov 19 2019 linux-i386
drwxrwxrwx 3 apache apache 40 Nov 19 2019 osx
drwxrwxrwx 2 apache apache 55 Sep 22 12:39 stretch
drwxrwxrwx 2 apache apache 133 Nov 19 2019 win

Hi @gomi

We just released a new release (9.6.006), which contains the last update for WKHTMLTOPDF

Please, update your environment and verify if the problem is solved.

Once again, sorry for the inconvenience of waiting.

The Problem is not solved.
After you marked the topic as solved I created a new one

1 Like

I am on Ubuntu20.04. Just purchased, installed and tried Export PDF and wkhtmltopdf is ver. 12.4 and doesn’t work because it doesn’t support https.
I have installed 12.5 and it works fine.
I hope the latest version, 12.6, also works.

I post here a solution that I found after a problem on an OVH Public cloud instance (linux ubuntu 20.04)
May It’s help some of you to resolve the same issue.
First go to the directory
# cd /var/www/…/_lib/prod/third/wkhtmltopdf/linux-amd64
Run the command you found in the .log in _lib/tmp/
# sudo -u www-data ./wkhtmltopdf-amd64 --page-size A5 […]
You will see the kind of problem you have.
In my case It missed somes librairies - PB resolved with :
# apt-get install libfontconfig1 libxrender1
Hope it’s help some of you

hi @robertoferraz
My server is
Operating System: Ubuntu 22.04 LTS
Kernel: Linux 5.15.0-50-generic
Architecture: x86-64
export to pdf function doesn’t work.
The export page stop here.
c31154787ea3b7dc8bf4c344e77bb2e
here is the tmp folder info under the dir /_lib/
image

is this the problem about wkhtmltopdf?

I am getting same error with Linux Centos:
image