Themes - Advanced edit, unable to save changes?

A little help please…
I am running SC
Version 7.01.0014
Types Professional Edition MySQL Bronze
Running on MAC OSX Zend Server

I have a theme that I copied from a SC theme and renamed, now a public theme.
My problem is I wish to make changes to some elements located within the “Advanced Edit” section. I can access them but can’t save changes? they just revert to original values.
I thought it would be a file permission issue so chmod -R 0777 /usr/local/zend/apache2/htdocs/scriptcase7/app/MY_APPLICATION/_lib/css and restarted server without any success.

Am I missing something…


Maybe you need to have admin rights to save the file??

Hi - Thanks for that, I have checked in SC, I am the only user and have all privileges checked?


I meant in OSX. As you know for some things in OSX you need to click a popup box and specifically allow it (kinda like in windows). My quick guess is that that is happening here as well. So the file permissions may not be the issue, the rights of the user may be. Also you should check your settings whether you allow applications to run that are not installed via the apple store. On maverik running applications that are not from the store can be blocked (a popup normally appears though). I dont have my mac here with me so describing it from memory is not really complete.
Please check these settings:

I guess the fault is partly also from scriptcase. I would not be surprised to find out that they didnt register as an identified developer properly and thus havent added the proper validation certificates. But I could be wrong in this… I havent tried to install scriptcase on osx…

Thanks and an interesting line to follow. I changed the 'accept Software from" to anyone. Restarted everything and no difference.
Out of interest… it does save the quick edit options, just the advanced which does not ???


I believe this issue is related to (lack of) permissions.

But I will verify the issue with our bugs team.

Bernhard Bernsmann

No, it has nothing to do with permissions. It just doesn’t work.


I’d have to install sc on my mac for that to see what the issue is… I think that is work for sc themselves to check it.

I’ve solved changing php.ini

Switches and enables
max_input_vars = 2000
Restart apache server