Trouble logging into Production after Deployment

I generated my website and with worked just find in the Scriptcase environment. To make sure I was using the correct database connections, I even connected to my hosted database during development.

Once I was finished, I zipped up the entire application and deployed it to my server. But once my files were unzipped, I attempted to execute and received the following error:


The database connection that your application use was not found. You need to access the production environment and create the connection.

Connections not found: farmcast_mysql

Click here to create the connections now. [/I]

So, I clicked on the link and then got the following message:


The default password to access the production environment is scriptcase. After your first login, you will be prompted to change it for security reasons.

The interface accepted the word “scriptcase” as the first production password, but it totally rejected the new password that I was instructed to enter. At least I’m assuming my password rejected because after I entered and confirmed a new password, I was returned to the previous message restating that my production environment password is scriptcase In other words, I was put into a loop and have not been able to get past this point.

Can anyone recommend a way to fix this issue?

Set your _lib tree to 777, make the changes and revert back to 644. I think it’s a rights issue.

Thanks Aducom,

I used Parallels Panel to set the _lib tree to READ/WRITE/EXECUTE because I am assuming that is what the 777 setting does. However, I am still stuck in the Production log in loop.
The only thing I can surmise is that setting the _lib tree to READ/WRITE/EXECUTE is not the same as setting it to 777 - which doesn’t seem likely. Do you think that is a possibility?

Please Advise


Afaik, no. 777 is full access which is rwx. You could retry uploading the full story because something might have went wrong. I had a problem like this in the past too, but I can’t remember what’s causing it. But setting up the primary access needs some files to be written. Does parallels also 777 the underlying folders when you change the rights for the parent? It might be that your subdirs remain the low rights. I’m not a plesk guru, so I don’t know.

I used SmartFTP to set all my directories in _lib to 777 -R. But for some unknown reason, I am still not able to get past the original Production log on window. As you can see in the attached .png file, all of the files and sub-directories under _lib tree
are set to 777 (rwx, rwx, rwx).