Unable to configure Production Environment after Upgrade to SC 9.9.024

I have upgraded my project to SC 9.9.0024 (was using SC 9.9.007), but new I unable to configure the Production Environment db settings when performing a fresh install of our project.

After installing my Project I have the new SC screen to configure the Production Environment. After entering the recovery email, password and captcha, it then loops to redisplay the message “Welcome to the Production Environment”.
If I install a previous build of our application built using SC 9.9.007, configuring the Production Environment works fine (using the previous screen).
How I get this to work?
Kind regards,
Trevor Dykstra

Just an update on a temporary fix:

After much testing (including manually installing the SC 9.9.024 production files on our production environment) I noticed the following in my apache log:

[Mon Nov 06 08:31:28.590528 2023] [php7:warn] [pid 979] [client] PHP Warning: file_put_contents(/opt/webapp/_lib/conf/prod.rec.conf.php): failed to open stream: Permission denied in /opt/webapp/_lib/prod/lib/php/devel/class/page/nmPageProdLogin.class.php on line 163, referer:

[Mon Nov 06 08:31:28.590898 2023] [php7:warn] [pid 979] [client] PHP Warning: file_put_contents(/opt/webapp*/_lib/conf/prod.config.php): failed to open stream: Permission denied** in /opt/webapp/_lib/prod/lib/php/nm_ini_lib.php on line 152, referer:*

After changing the permissions of the _lib/conf/ folder to rwxrwxrwx it worked (I had also tried using rwxrwxr-x but it still didn’t work)

It’s a security risk having the permissions as rwxrwxrwx so I’ll have to see if there is something else I can try, but it did temporarly fix the issue.