Urgent Deployment Help Needed


I have just deployed my project but it will not work.

I uploaded all the files to my subdomain on my production server - I went to the url in a browser and clicked the ‘create connection’ link.

I then changed the password and entered my details and ultimately went to my login screen (‘app_Login’).

I then realised that I had negelected to grant security permissions etc. So I deleted all files from the server and started the deploy process again.

Now when I go to URl I see the ‘create connection’ screen and click the link but I end up in a loop on this url:
with the error: The page isn’t redirecting properly

I have tried the entire process several times but always the same error.

Please can anyone suggest what might be causing this. I need this live now and my client is going mad!

I have opened a support ticket but no reply so far.

many Thanks

Did you delete only the files or also the directories? Can it be that the undelete was not complete? I would delete all again, remove all directories and restart from there. It might also be that the upload went wrong. I don’t see why you went into reinstalling because of grant issues. Could it be that the new settings are interfering with what you want? Finally, you could try to upload into another subdomain, i.e. cc2

Hi Albert
Thanks for your response.
I got a response from Scriptcase. They asked me to make sure that when I re-uploaded that I had changed the permissions on _lib 777-R. I perform my permission changes using FileZilla and had done this.

To answer your questions:
I did delete all files & directories from the server before re-uploading and going through the rest of the process. I have tried unzipping and deploying it on my local machine and it all works so I don’t think what I did with permissions is the problem.

I am just FTPing the unzipped files from local machine to my production server to see if that makes any difference. If it doesn’t then I will create another sub-domain and try that.

I’ll let you know how I get on and again, thanks for your response.


Scriptcase has a nasty habit of storing the configurations in PHP Session/Cookies. I ran into this issue couple of times where I removed the configruation files but Scriptcase kept referring to the old settings stored in my browser cookies. So, I recommend try the following:

  1. Delete all your files
  2. Reupload all your files
    3/ CHMOD -R 777 /_lib/ directory (recursively CHMOD 777 _lib and all the files/folder under the _lib directory)
  3. Clear your browser’s Cache and Cookies (for your domain or all)
  4. Visit the URL and trying creating the connection file etc…

See if that makes a difference!

I have SC apps running in linux distributions and I don’t like/recommend using 777. Perhaps until the application is setup, then I would recommend to go back to 744. I never needed 777 to get it installed by the way.

Thanks for the suggestion - I have deleted all cookies and hostory relating to this domain and subdomain but it has made no difference at all.

I am now trying Alberts other suggestion of creating a new subdomain and starting everything from the beginning.

Thanks for the permission suggestion. I will start with 777 and then change to 744 once I have it all working.

This is really wrecking my head now!

I have setup a new subdomain, removed all of the URL output for security on every application, run the deploy routine, upload the zip file, extract, change permissions using filezilla on _lib 777 recursive, clear history and cookies in my browsers and still doesn’t work.

I get the create connection on the following url: xxx.xxxxxx.com/app_Login/app_Login.php
When I look at the URL of the link it is: xxx.xxxxxx.com/_lib/prod/lib/php/nm_ini_manager2.php but when clicked it gets caught in a loop displays ‘Page isn’t redirecting correctly’ or ‘This webpage has a redirect loop’ depending on browser and the URL is:

I just can’t figure this out. It seems that something in nm_ini_manager2.php could be the cause but I really don’t know.

I think I am going to get some sleep and then, in the morning, copy all of my applications to a new project but do not copy security apps. Then create security in the new app and then go through the whole deploy process again. It takes ages because my connection is so slow. Hoping that will fix it.

If anyone has any ideas before I go through all that work in the morning I would be delighted to hear them - Fingers crossed!


I went ahead and created a new project and copied my apps over without security and they work.

I’ll add security in the morning - Have to sleep now!

Anyone know how to move themes from one project to another? I moved the files that I could find and my custom themes are working when test locally but they do not show-up in the new project when I go to edit themes.

Go to project -> properties and add the theme(s) to your project. You need to declare which themes you want to use with your application.

I just don’t know what is wrong here.
I have create a new project and imported all of my applications - Then I have recreated the security, created the deploy zip, uploaded, extracted, changed permissions on _lib but it is still failing.

Still caught in a loop and trying to display: xxx.xxxxxx.com//_lib/prod/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login/app_Login.php

I am using Hostgator - Is this perhaps the problem?

Any ideas?