UUID Postgresql

I am using my Postgresql database to generate my UUID unique identifiers.


CREATE TABLE tbl_0_account2(
account_id UUID PRIMARY KEY DEFAULT uuid_generate_v4(),
account_no text NOT NULL,
account_name text NOT NULL

Which works fine in the database.

When I create a single form in Scriptcase and for the field “account_id” uses “Text”, and Activate “New”, “Update”, “Read Only”, and select the DB Value(Insert) “Calculated by the database”, Scriptcase returns an empty screen when I run the app.

If I also activate “Required” Scriptcase returns “Account Id: Required field” when I run the app.

I have tried many other combinations, with no success.

I would really appreciate a solution, thank you.

Though this isn’t a solution, I’m very interested in any replies you get.

In PG, I find that I’m better off to use normal INT PKs, and also have a unique UUID column. That way SC is happy with expecting an INT, and you can also grab the UUID as needed. I’ve had other apps prefer this approach as a workaround…

1 Like

I was informed by scriptcase support that uuid is not currently implemented in scriptcase. I have made a suggestion to the development team as advised.