Deploy: Cannot change default "scriptcase" password - endless loop

Hello, I am currently evaluating Scriptcase and am short of buying a license.

HOWEVER, today I wanted to test deploy my application and cannot connect my mysql database, because I cannot get past the changing of the default production environment password! I’m in an endless loop without any error messages. Not very impressive…

I mean, if I cannot do it, how should my customers? At least there could be a message “no directory access”, or whatever is causing this.

Windows Vista
Deployment to local IIS folder for testing purposes
All users on my machine have all R/W/X rights to the deploy folder & subdirectories
I have no problems with any other PHP applications running on my local IIS

So now I am stuck and in some real doubts.

Can anyone help?
Anyone from support listening?

There’s a similar thread here with no solution:

The settings are stored somewhere into your _lib path. So try to set the rights of _lib to 777 and retry. After storing the password revert back to 644. If that’s not helpful try to re-upload as there might be some kind of corruption.

As I said above:

  • I am using local IIS
  • I have ALL rwx rights (asssuming this is 777) on ALL fooders and subfolders
  • I have no problems with any other PHP apps
  • I just redid a complete deployment to my LOCAL wwwroot folder (no upload)

And I’m still stuck in an endless password loop.





view uploaded screenshots in reverse order :wink:

Yes, but has “PHP-User” / IIS-User also all rights? The php script is not running under your name …

Thank you - no success however.
To make sure, I already gave all users FULL control in Windows, incl. the IIS_IUSR group.

Everybody on my local machine has all RWX access to the deployment folder incl. subfolders.

Just for info I have included a screenshot of the application pool, which uses the default builtin NetworkService account.

I have no problems with other PHP applications, even if they need RW access.

I am slowly loosing faith. Maybe someone from the support team can show up and prove that this is a product worth buying and that I didn’t waste 3 days testing & learning it.

Or is there anyone out there who made a successful deployment to IIS? For info, Apache is not an option for me.



Check, if IIS use the temp dir (C:\Temp oder C:\Tmp or so) and give IIS_IUSR_* rights to this dir.

[SIZE=1](Das muss einfach laufen, aber IIS ist ein Luder …)[/SIZE]

I overlooked the IIS thing. I might miss the appropiate knowledge, but I had enormous problems getting things to run on IIS above 2003 server. IIS has become too complex imho and I was not able to fix all issues I got when I moved to W2007 server. Now there’s 2012 server and I wonder. Unless you are a guru on IIS I strongly advise you to stop the server and start using an apache based install like Uniform or a similar wamp. Most installations run this and with problems/questions there are loads of forums to get help from…

I’m running IIS on my local Windows machine and on my Windows 2008 R2 webserver. I have many apps and all are working fine. I am quite happy with IIS, and I don’t want to install Appache & IIS parallel. And I also don’t want to learn a new cryptic config script language in Apache, because no-one of the Scriptcase development team seems to have noticed that there are millions of happy IIS users out there. And without wanting to be impolite, mostly Linux/Apache fans say that IIS is garbage.

So Apache is not an option for me. Either there is someone in this forum who has successfully deployed a Scriptcase app to IIS, or the support team cares enough about new customers to answer my question. I cannot spend $ 500 on a product that lacks essential support on this topic.

Hello Suport, are you listening at all? Or who can I contact directly with this problem?

I’ve spent 3 days evaluating & learning, but I seem to have reached a dead end. Nice videos, but how about a short tutorial on how to deploy on IIS?

Alternatively, can I edit the necessary deployment setup manually and insert the correct mySQL link?

Only 3 days? Ok, then you can not expect much … :wink:

Please, let us continue to work on the IIS problem and bide the rest of the outside.

Apache is not an option and that I need an IIS solution, otherwise I cannot buy this product.

Is there no-one who has successfully deployed an app on IIS and can help me?
Is there anyone else who has this endless password loop?
Is there any way of editing a config file manually and setting the mysql connection in order to get past this “password change” loop?

All my PHP apps run fine, and ALL users have ALL rights to ALL folders and subfolders.

Reinhard, I cannot hide my frustration over evaluating a product for 3 days, finding it very useful and then not getting through the password door. Three days is a lot of time & money for my project time plan.

I will not discuss Apache vs. IIS …

I also do not know what the problem is exactly, but certainly i want to help you. But please, no discussions about other programs which runs. That is not interested here.

If you are evaluating scriptcase you can always make use of Scriptcase support. It’s quality might not be good on every occasion but it’s being improved significantly currently. I would advise you to use a live chat. Did you already tried to re-upload by the way? I have had this problem once and it solved my issue.

Reinhard, my advise of apache was not meant as a discussion between IIS of A. I have ran IIS a long time and it’s a very good webserver. But the issue currenlty is as far as I can see an IIS issue and not a Scriptcase issue. And as there are thousands of options to set in IIS it’s like searching for the needle in the haystack and virtual impossible to answer with the limited information we have.

Yes, it’s a IIS issue …

I have setup an IIS 8 installation for @hkuersten and install one of my sc projects. I can’t write the configuration (endless loop). But, i have searched at google and found a solution: Click! This solution is for wordpress, but with minimal changes (#12 - #17) my sc app is running on IIS 8 ;).

>> Select Anonymous Authentication and in the Actions pane on the right side click “Edit”
>> Then select “Application Pool Identity” and click OK

That did it - Thank you so much Reinhard, you saved my day!
That was indeed a hidden option, which I have never needed before…

It would really help those… crazy & remote IIS admins and potential ScriptCase customers, if there was a help topic on IIS deployment somewhere :slight_smile:

Which rests my case. But I’m glad that the issue is solved though.

My relief was a bit too early - this deployment is turning out to be a bit of a horror for me :frowning:

In the production environment I cannot connect to the mySQL database, even though in my dev environment I have no problem running my app.

Now what?