Move Project Files and Settings to New Installation of SC 8

My development machine (MacBook Pro OSX Yosemite) crashed the other night and the next day I could not access SC 8 through the browser. After several failed attempts, I backed-up my current installation files and re-installed SC 8. The new installation worked fine except, of course, there were no project files or settings.

How can I migrate my existing projects and settings to the new installation? I’m finding just moving the files from the backup to the new installation doesn’t do anything. I don’t have current backups of the projects to import them. (I know, I know…)

Any suggestions are greatly appreciated.

Make a new full backup (turn off sc first of course) of your sc directory.
Locate in the old backup the nm_scriptcase.db database it should be im the wwwroot\scriptcase\devel\conf\scriptcase dir.
See if you have an nm_scriptcase.locked or .db.locked in there. That signifies that your database is locked and something hasnt finished (update/delete/insert).
If needed repair that database file (be very very carefull!!). Check if you can open that database file and do NOT change anything in it. You will seriously damage your applications and even the workings of sc itself.
Copy this old db file on place of your new installation and start your sc and see if it works.
With some luck you can enter into your old application. If so then quickly export all your projects. Then turn off sc, restore your new installation that you have backed up and import your projects.

No guarantees in this and do only do this on the machine you already had installed your sc on.
Tip of the day… Make regular full backups of the entire sc dir. That will save you a lot of trouble… At least do that before doing ANY upgrade. And only backup if sc is turned OFF.

Thank you, rr. Basically, these steps worked. I was able to recreate the projects and settings in a new installation (on another machine/server) and then backup everything, install a NEW SC 8 on my original machine/server and import/restore the backups. There were a few small hiccups but I was able to save everything.

hi, i followed above steps and was able to recover the projects. However, i notice that all my CSS themes and Libraries are missing. is there anything else that i can do to ensure i recover these missing themes and Libraries? Your usual support is always appreciated.

Too bad that you did not backup you css… You can stop the scriptcase apache webservice, rename the scriptcase v8 dir to v8old.
Then get your previous version back, start the apache service (speaking windows here) login and export your css files.

Alternatively your css files are in your devel\conf\sys\meu\Scriptcase dir. AS far as I know you also must copy the ini file of your css as well.
Be carefull tho, when fiddling always first make a full backup!

O yes I found some css on our system under the devel\conf\usr\ subdir under a legit user on our system.
So I guess that is possible too.

As far as I know your libraries are in your database and can not be retrieved in any easy way.

Since this is a recovery operation all I would do is use the fact that you already made deployments, in that deployment there would be your libraries. So all you ned to do is to find them.
I dont know by head where they are, you can find it somewhere but I just didnt ever need to. Use a tool like total commander or so to search through the directories.

thanks rr for the reply, i was able to find the libraries in devel\conf\grp’projectName’\lib

as u rightly mentioned, i located the themes in devel\conf\sys\menu\Scriptcase

and yes i’ve always backed up my projects until a month ago when scriptcase suddenly started giving me errors each time i tried backing up. one month work was just too much for me to lose after this upgrade from scriptcase8 to scriptcase8.1 hence the need to manually restore my projects rather than restoring from a one month old backup.

Glad that it worked… I suggest strongly that before ANY update of scriptcase you make another full! backup of the v8 dir.

rr: you’re a lifesaver!!! You just spared me a myocardial infarction. Thank you very much!

Thank god I found this post. I swear I’m gonna backup everyday after this.

I ticked the
Use session in database
under Settings -> System Settings, logged out, and when try to login it says another user already logged in. I clicked OK and then I am forever stucked at login screen indefinitely (indicating something has corrupted with the installation/configuration).

I panicked and reinstall scriptcase. Luckily I did backup the wwwroot folder (didnt backup the whole sc due to not enough space).

Thanks a million!

After importing the project, the dictionary is there but the Application Language gone. Managed to repair it by restoring this file from backup copy.
C:\Program Files\NetMake\v9\wwwroot\scriptcase\devel\conf\grp[project name]\lang\en_us.lang

Hope it helps someone.