ScriptCase 8 - Bugs


I’m creating this thread to act as a central point of all ScriptCase V8 bugs. Please report any bug that you are facing in this thread, regardless of wether it is only happening to V8, or if it is a legacy bug (also present in any older version).

Bernhard Bernsmann

Hello Bernhard. I have SC 7.1 and have read 8 can run side by side with an older version. Reading the manual installation manual, the steps are: Download new version. Unzip. Rename folder to scriptcase. But the version 7.1 has already the name scriptcase. Can V8 run as scriptcase8 or should I rename the v7 folder to scriptcase 7? In any case, both versions will continue running. Right?

Date Field Does Not Export to XLS as Configured and cannot be Sorted Cronologically.

Vertical Scroll Bar in Group By Modal Window is required. If you have a number of fields that the usercan select, which is commonplace if they want to export the Group By table to Excel, not having scroll bars limits field selection, drag and drop, at both the top and bottom of the list.

Hi german6547,
Even though the question is not addressed to me, but in the spirit of helping, I can tell that you can name the folders containing ScriptCase after any one you choose to, i.e. my SC v7 is named as sc7, and now my SC v8 is named as sc8.

Best regards,
Ivan Saavedra Maufras

Rename V8 folder to scriptcase8.

Rename V8’s folder to scriptcase8.

Or to sc8 as Ivan suggested ;D

In a grid application, creating a run button the image selector icon is not working, it is not forwarding to image selection window. Tested with chrome and ie8.


Menu tree does not seem to be able to resize even though the resize option is enabled.

Error with filter sb8

Hi, i am testing v8 when i use Grid dynamic filter and my filter is CREDITLIMIT LESS THEN 1000, show not records found! (i can see records exists)
attach image.



When adding two editable grid views - one is showing a horizontal scroll bar and the other is not. They are the same size. Please fix.



If you have set up To Do’s, and then open an app that has a To Do associated with it, the To Do pop up shows:

It shows “$s” instead of the number of tasks…




Viewing a project on a mobile: top level menus, when clicked, ONLY show sub menu items - if that top level menu item has an app associated with it you cannot run it!

If seen on a PC browser though, then the top level menu item, when clicked, shows the sub items, but I can still click on the top item and run the app associated with.

The pdf report doesn’t fit,

First impression: 20% of everything is squirrely, and 10% is broken.

Compare with 4% squirrels / 1% broken on v7.

Imported 65 v7 apps via File->Import Project:

Dynamic Group By appears clickable but does nothing. There’s no + beside it and the interface does nothing when it is clicked. The documentation implies that this must be enabled, but where?

Edit button is missing on Grid apps. Detail only. (SC security isn’t used)

Grid/Settings no longer has the width spec, and the project defaults (Options/Settings/General/Grid) are completely ignored just as they were in v7. Grid width seems hard-coded to “random”.

Meme d’ jour: Son, I am disappoint.

Edit: Dynamic Group By breaks because the app was imported. Doing a batch-create makes DGB work, but all of your prior work is lost. Hey, we’re all billing hourly, right? Right?


When I click the save/build/run button I get an error “Can’t identify the server. Contact NetMake.” I’m using a connection that tests OK. That button, other than the really irritating help bubble that covers things I’d like to stab with my cursor, works just fine with the imported apps that don’t work (it builds/starts the imported apps at least). Imported apps don’t work after they start, and new apps don’t start at all.

Deploy in advanced mode produce a common library file named sc_prod_7.1.010 (!) insted of

The On Record Event on pdf application does not exist!!!

The image on the pdf dos not escale correctly

V8 - Project not importing

I upgraded from 7.1 to 8 this morning. I have imported all my projects fine except one, which is the one we develop on the most. It’s also the largest project of the bunch. When I import the file for that project, it appears to run fine, prompting for the new project name (which like the others I imported successfully, I don’t change) and then it stops as though it’s finished. But when I go to look at my projects, I see them all but this one. After trying the import again, I noticed this text below the summary window (see attached). What could I be doing wrong in this case to make it fail? Or what should I change to get it to import correctly?

I’m running V7.1 and 8 as separate apps on my Windows 7 machine.

Thanks very much,



Edit: Well that image attached is pretty much useless. Here’s another link to it:

Edit 2: Stranger is what I notice when I start studying the picture. The grid_Passwords app, referenced in the pic - I wondered if that particular app in my project was causing the issue. So I unzipped the backup, removed that particular app, and zipped it back up. Then ran the import, and it imported with out error… There must be something in that particular app that was causing a problem. Recreating one app wouldn’t be too big a deal for me if that’s all it was. If I still have issues on this particular ticket, I’ll post them here.

Final Edit: Scriptcase 7.1 didn’t mind an extra comma in the grid’s sql code… I copy / pasted the sql into another app, and it failed. Upon further inspection, my last column I was pulling in the code had a comma after it. I looked again at 7.1 and sure enough - there was a comma in it and it seemed to work fine. So I took the comma out and voila - all works fine. Feel free to delete this - sorry. Posting the issue did help me step through it all though LOL


Funny thing with that, if you use a project-search to find something, which is inside the on_record-event, it is found, but not shown in the event list.
The on-record-event is existing, tested it with an converted project. It is just not shown, something like a missing flag for that event to show in an pdf-report.



Dynamic summary/groupby does not word if the grid is integrated in container, tree menu or menu. I also tried your sample apps, got the same result like my app. Please check and fix.