Select based on date field changes format in _onChange ajax event

In my form, I have a select field that populates so:

SELECT distinct(ExpirationDate) FROM stock WHERE ProductID = {ProductID}

It correcty shows all the dates available in the select list in this format:


The initial load correctly pulls in the date in this format. However, once you select another date in the field, it seems to be switching the format to DD-MM-YYYY but muddling it up as MM-DD-YYYY (see screenshot below from switching on debug mode.)

Since this is a drop-down select (and not date) I’m not able to configure regional settings etc for the date.

I have tried different settings in Locale ==> Regional Settings but no difference.

Anyone encountered and resolved similar?

I’m on the very latest 9.6.001


Hi, try this

SELECT DATE_FORMAT(fecha, ‘%m/%d/%Y’)


@aamartinezz: thanks, had tried but didn’t work.

Solved by temporarily changing the field to date, turned off regional settings, set display to yyyy-mm-dd, saved the form then changed it back to Select type field.

hiii scriptcaser…please check your inbox…thanks