[SOLVED] Cookies/session stuck, cannot login into scriptcase

Hi everyone,

so i cannot login into scriptcase because the session is stuck. Normally you can just disconnect the
session by clicking the “disconnect this user” link. But in this case, it just keeps redirecting me back to the login page.


the yellow highlighted session is stuck. note that the session id is also blank.

can anyone help me please?

To overcome this and other problems related to the sessions that remain hanging, I created an application that manages the sc_tbati table in the repository database but is not risk-free :wink:

1 Like

Hi gbravi, thanks for the response.

how can i acces the sc_tbati table in the repository database ? is it password protected?

it works, Thanks gbravi !

You are welcome.
Glad I was helpful.

I had the same trouble today, at first not knowing what was going on.
No error nothing showed up… but I realized that the last time I was logged into the scriptcase development dashboard, I was at home, on a different IP and I logged in with ‘keep me logged in’

So what had changed, we visited our parents in law, so I tried to work there over VPN connected to my home network.

Searching a couple hours for the cause of not being able to log into scriptcase, I found this session locking (bug or a feature :slight_smile:

Also found that you need to check the sc_tbati table:
…/scriptcase/devel/conf/scriptcase/nm_scriptcase.db

I opened this file with the program ‘TablePlus’ and cleaned the table by the SQL command:
delete from sc_tbati

But I still could not login… the I noticed that there still was my Home IP in an Column at the table:
table: sc_tbusu
column: Ip_Uacc

Again with TablePlus I ‘manually’ added my the IP from the parents in law internet gate into this column ‘Ip_Uacc’
And voila access was possible again.

Keep in mind to make an backup from the nm_scriptcase.db !!!

Hope this helps with this kind of session troubling…

1 Like